Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Super SIM Network Connectivity Issues
Incident Report for Twilio
Resolved
We are no longer experiencing Super SIM connectivity issues. This incident has been resolved.
Posted Oct 13, 2020 - 04:21 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 13, 2020 - 04:21 PDT
Monitoring
We are now seeing recovery of the network connectivity issue. We are continuing to monitor for service stability. We will provide another update in 2 or as soon as more information becomes available.
Posted Oct 13, 2020 - 02:25 PDT
Investigating
We are experiencing Super SIM connectivity issues with one of our partners. We are experiencing delayed attachments for a subset of customers. Existing sessions should not be affected. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 13, 2020 - 01:46 PDT
This incident affected: INTERNET OF THINGS (Super SIM).