Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Timeout Errors in Twilio Flex, Chat, and Sync
      Incident Report for Twilio
      Resolved
      As stated in our last update, we are resolving the incident.
      Posted Sep 22, 2020 - 12:33 PDT
      Update
      The issue causing timeout errors when establishing client connections in Twilio Flex, Chat, and Sync has been resolved, with an exception for a couple customers on Programmable Chat. We are working directly with these customers, and hence are resolving this incident on StatusPage.
      Posted Sep 22, 2020 - 12:28 PDT
      Update
      We are seeing partial recovery for timeout errors when establishing client connections in Twilio Flex, Chat, and Sync, and our engineering teams are continuing to investigate. We expect to provide another update as soon as we have more information.
      Posted Sep 22, 2020 - 11:30 PDT
      Update
      We are continuing to investigate timeout errors when establishing client connections in Twilio Flex, Chat, and Sync. We expect to provide another update in 1 hour or as soon as we have more information.
      Posted Sep 22, 2020 - 10:29 PDT
      Update
      We are investigating timeout errors when establishing client connections in Twilio Flex, Chat, and Sync. We expect to provide another update in 30 minutes or as soon as we have more information.
      Posted Sep 22, 2020 - 09:51 PDT
      Investigating
      Our monitoring systems have detected a potential issue with connection errors to twilsock. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 22, 2020 - 09:28 PDT
      This incident affected: FLEX (Flex Application Platform, Flex Insights), SERVERLESS (Sync), and PROGRAMMABLE CHAT.