Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound SMS Delivery Failures to Twilio Israel Numbers
      Incident Report for Twilio
      Resolved
      The issue affecting inbound SMS delivery delays for a subset of Israeli Domestic Longcodes has been resolved, and the service is functioning normally at this time.
      Posted Jul 26, 2022 - 01:48 PDT
      Monitoring
      We have started seeing recovery for the issue causing inbound SMS delivery delays for a small subset of our Israeli Domestic Longcodes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 25, 2022 - 23:48 PDT
      Update
      We are still experiencing inbound SMS delivery delays for a small subset of our Israeli Domestic Longcodes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 25, 2022 - 21:48 PDT
      Investigating
      We are experiencing Inbound SMS delivery delay for a small subset of our Israeli Domestic Longcodes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jul 25, 2022 - 20:48 PDT
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).