Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SIM Status update delays
Incident Report for Twilio
Resolved
As of 5:14PM PDT, all SIM updates are successfully being processed.
Posted 8 months ago. Jun 21, 2018 - 17:16 PDT
Investigating
At 3:38PM PDT we started experiencing delays updating status and changing rate plans to SIMs. We will provide the next update in 1 hour.
Posted 8 months ago. Jun 21, 2018 - 16:22 PDT
This incident affected: PROGRAMMABLE WIRELESS.