Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Report Delays on a Small Subset of Messages Sent on Twilio Short Codes in the US
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages on Twilio Short Codes in the US. This incident has been resolved.
      Posted Jun 21, 2022 - 10:10 PDT
      Monitoring
      We are observing recovery in receiving message delivery reports on a small subset of messages when sending on Twilio Short Codes in the US. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 21, 2022 - 08:17 PDT
      Update
      We continue experiencing delays in receiving message delivery reports on a small subset of messages when sending on Twilio Short Codes in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Jun 21, 2022 - 00:11 PDT
      Update
      We continue experiencing delays in receiving message delivery reports on a small subset of messages when sending on Twilio Short Codes in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Jun 20, 2022 - 23:25 PDT
      Update
      We continue experiencing delays in receiving message delivery reports on a small subset of messages when sending on Twilio Short Codes in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Jun 19, 2022 - 23:26 PDT
      Update
      We continue experiencing delays in receiving message delivery reports on a small subset of messages when sending on Twilio Short Codes in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Jun 18, 2022 - 23:26 PDT
      Update
      We continue experiencing delays in receiving message delivery reports on a small subset of messages when sending on Twilio Short Codes in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Jun 17, 2022 - 23:26 PDT
      Update
      We continue experiencing delays in receiving message delivery reports on a small subset of messages when sending on Twilio Short Codes in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
      Posted Jun 17, 2022 - 07:26 PDT
      Update
      We continue to experience delays in receiving message delivery reports on a small subset of messages when sending on Twilio Short Codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted Jun 16, 2022 - 23:43 PDT
      Update
      We continue to experience delays in receiving message delivery reports on a small subset of messages when sending on Twilio Short Codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Jun 16, 2022 - 19:43 PDT
      Update
      We continue to experience delays in receiving message delivery reports on a small subset of messages when sending on Twilio Short Codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 16, 2022 - 17:43 PDT
      Investigating
      We are experiencing delays in receiving message delivery reports on a small subset of messages when sending on Twilio Short Codes in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jun 16, 2022 - 16:44 PDT
      This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks).