Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures To Telin Timor-Leste
      Incident Report for Twilio
      Resolved
      After investigating the SMS delivery failures To Telin Timor-Leste issue with our provider, we are able to determined that there is no noticeable customer impact. All systems are operational.
      Posted Aug 18, 2022 - 08:13 PDT
      Update
      We are experiencing SMS delivery failures To Telin Timor-Leste. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 18, 2022 - 06:57 PDT
      Investigating
      We are experiencing SMS delivery failures To Telin Timor-Leste. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Aug 18, 2022 - 05:57 PDT
      This incident affected: CARRIER NETWORK (SMS, APAC).