Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delayed Outgoing Shortcode MMS
Incident Report for Twilio
Resolved
Outgoing shortcode MMS was degraded between 9:56 and 10:58 Pacific Time on 02/22/2021. During this period, customers may have experienced delayed outgoing shortcode MMS messages, or expired messages if a validity period was specified. The issue has now been resolved.
Posted Feb 22, 2021 - 11:48 PST
Investigating
Our monitoring systems have detected a potential issue with outgoing MMS. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Feb 22, 2021 - 11:25 PST
This incident affected: PROGRAMMABLE MESSAGING (MMS).