Voice Call Post Dial Delay from Twilio Phone Numbers to United States has been resolved and is operating normally at this time.
Posted Feb 23, 2026 - 16:36 PST
Monitoring
Voice Call Post Dial Delay from Twilio Phone Numbers to United States are now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 23, 2026 - 16:07 PST
Update
Twilio customers may continue to experience voice call post dial delay from Twilio Phone Numbers to network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 23, 2026 - 14:12 PST
Investigating
Twilio customers may be experiencing voice call post dial delay from Twilio Phone Numbers to network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 23, 2026 - 13:12 PST
This incident affected: CARRIER NETWORK (Voice, North America).