Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery delays and non-deliveries to Multiple MTN Networks across African countries
Incident Report for Twilio
Resolved
All systems are operational
Posted Jan 19, 2020 - 12:20 PST
Identified
We have been observing message delivery delays and non-deliveries towards the MTN network in African countries.
At the moment this issue is affecting the following countries: Nigeria,
Ghana, Rwanda, Cameroon, Benin, Uganda and Sudan. MTN have identified the issue and are working towards restoring service as soon as possible.
We will provide an update as soon as we have additional information or updates.
Posted Jan 19, 2020 - 06:20 PST
Update
We continue to work with our carrier partner to resolve the issue. We will provide an update as soon as additional information is available.
Posted Jan 18, 2020 - 23:11 PST
Update
We continue to work with our carrier partner to resolve the issue. We will provide an update as soon as additional information is available.
Posted Jan 18, 2020 - 09:37 PST
Update
We continue to work with our carrier partner to resolve the issue. We will provide an update as soon as additional information is available.
Posted Jan 18, 2020 - 00:59 PST
Update
We continue to work with our carrier partner to resolve the issue. We will provide an update as soon as additional information is available.
Posted Jan 17, 2020 - 17:06 PST
Update
Message delivery to multiple MTN networks, now including Zambia, is still delayed. We continue to work with our carrier partner to resolve the issue and will provide an update as soon as additional information is available.
Posted Jan 17, 2020 - 08:19 PST
Update
Message delivery to multiple MTN networks, now including Sudan, is still delayed. We continue to work with our carrier partner to resolve the issue and will provide an update as soon as additional information is available.
Posted Jan 17, 2020 - 04:48 PST
Update
Message delivery to the MTN network is still delayed. We continue to work with our carrier partner to resolve the issue and will provide an update as soon as additional information is available.
Posted Jan 16, 2020 - 21:51 PST
Update
We continue to work with our carrier partner to resolve the issue. We will provide an update as soon as additional information is available.
Posted Jan 16, 2020 - 17:13 PST
Update
We continue to work with our carrier partner to resolve the issue. We will provide an update as soon as additional information is available.
Posted Jan 16, 2020 - 12:31 PST
Update
This issue is now affecting the MTN Network in Nigeria, Ghana, Rwanada, Cameroon and Benin. Our engineers continue to work with our carrier partner to resolve the issue. We will provide an update as soon as we have further information.
Posted Jan 16, 2020 - 08:10 PST
Investigating
We are observing message delivery delays towards the MTN network in Nigeria. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jan 16, 2020 - 06:29 PST
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).