Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Latency and Timeout Errors with Twilio Rest API Impacting Multiple Products
      Incident Report for Twilio
      Resolved
      Our engineering team has confirmed the issue is now fully resolved and the affected products and services are now operating normally.
      Posted Dec 17, 2021 - 09:12 PST
      Monitoring
      We are observing recovery to the API degradation causing elevated HTTP 500 errors for SMS, MMS, Phone Numbers, Console, IoT and Rest API. We will continue monitoring the service to ensure a full recovery. We will provide another update in 30 minutes or as soon as more information becomes available
      Posted Dec 17, 2021 - 08:42 PST
      Identified
      We have identified the issue causing elevated HTTP 500 errors for SMS, MMS, Phone Numbers, Console, IoT and Rest API. Our Engineers have worked on mitigating the issue and we are seeing recovery of product and services. The next update will be in 30 minutes.
      Posted Dec 17, 2021 - 08:31 PST
      Update
      We are experiencing elevated HTTP 500 errors for SMS, MMS, Phone Numbers, Console, Programmable Wireless and Rest API. Customers may experience sign-up errors, the Buy a Numbers Page in an Endless Loop and unable to place orders for IoT products. Our engineers are working on the issue, and we will provide another update in the next 30 minutes or when more information becomes available.
      Posted Dec 17, 2021 - 08:13 PST
      Update
      We are experiencing elevated HTTP 500 errors for SMS, MMS, Phone Numbers, Console, Programmable Wireless and Rest API. Customers may experience sign-up errors, the Buy a Numbers Page in an Endless Loop and unable to place orders for IoT products. Our engineers are working on the issue, and we will provide another update in the next 30 minutes or when more information becomes available.
      Posted Dec 17, 2021 - 08:09 PST
      Update
      We are currently investigating an issue with latency and timeout errors on Twilio's Rest API. Multiple products are impacted. Our engineers are working on the issue, and we will provide another update in the next 30 minutes or when more information becomes available.
      Posted Dec 17, 2021 - 07:48 PST
      Investigating
      We've become aware of a potential issue with Programmable SMS and MMS. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Dec 17, 2021 - 07:35 PST
      This incident affected: DEVELOPER TOOLS (Console, REST API), PHONE NUMBERS, and PROGRAMMABLE MESSAGING (MMS, SMS).