The issue affecting degraded performance on Twilio Help Center has been resolved, and the service is functioning normally at this time.
Posted Feb 12, 2026 - 13:31 PST
Monitoring
We have seeing recovery for the degraded performance on Twilio Help Center. We will continue to monitor to ensure a full recovery. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Feb 12, 2026 - 13:15 PST
Identified
The issue affecting degraded performance on our account portal where the Twilio Help Center is non-responsive preventing AI chat conversations and submitting support tickets has been identified and our engineering team is implementing a fix. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Feb 12, 2026 - 13:06 PST
Update
We are currently seeing improved performance on our account portal as Twilio Help Center is responsive allowing AI chat conversations and submitting support tickets. Our engineering team is looking into the issue. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Feb 12, 2026 - 13:00 PST
Update
We are currently seeing degraded performance on our account portal where the Twilio Help Center is non-responsive preventing AI chat conversations and submitting support tickets. Our engineering team is looking into the issue. We expect to provide another update in 15 minutes or as soon as more information becomes available.
Posted Feb 12, 2026 - 12:54 PST
Investigating
Our monitoring systems have detected a potential issue with Help Center which prevents AI help support chat or submitting support tickets. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Feb 12, 2026 - 12:39 PST
This incident affected: TWILIO PLATFORM (Customer Support Center).