Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Support ticket submissions to support@authy.com failing
Incident Report for Twilio
Resolved
We've resolved the issue preventing us from receiving emails sent to support@authy.com.
Posted Nov 26, 2019 - 15:43 PST
Identified
We've identified an issue that has prevented us from receiving any incoming mail sent to support@authy.com since 11/17. Our team is working to resolve this, but in the meantime, support requests for Authy should be directed to https://support.authy.com/hc/en-us.
Posted Nov 26, 2019 - 14:53 PST
This incident affected: TWILIO PLATFORM (Customer Support Center).