Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS and MMS Delivery Delays to Multiple Networks
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS AND MMS delivery delays when sending messages to multiple networks within the US and Canada from a subset of Twilio toll-free numbers, long codes, and 10DLC. This incident has been resolved.
      Posted Sep 28, 2022 - 13:44 PDT
      Monitoring
      We are observing recovery in SMS and MMS delivery delays when sending messages to multiple networks within the US and Canada from a subset of Twilio toll-free numbers and long codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 28, 2022 - 12:44 PDT
      Update
      We are still experiencing SMS and MMS delivery delays when sending messages to multiple US and Canada networks from a subset of Twilio toll-free numbers and long codes. Our engineers are continuing to work with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 28, 2022 - 10:51 PDT
      Update
      We are experiencing SMS and MMS delivery delays when sending messages to US AT&T network from a subset of Twilio toll-free numbers and long codes. We are also observing SMS delivery delays to US T-Mobile network when sending from a subset of Twilio toll-free and long codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 28, 2022 - 10:00 PDT
      Investigating
      Our monitoring systems have detected a potential issue with SMS delivery delays. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 28, 2022 - 09:46 PDT
      This incident affected: CARRIER NETWORK (SMS Long Code, North America, MMS Long Code, North America, SMS Toll-Free, North America).