Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Usage Report Delays for Programmable Wireless
Incident Report for Twilio
Resolved
Usage report delays have been resolved and Programmable Wireless is operating normally at this time.
Posted May 12, 2021 - 15:46 PDT
Monitoring
Usage reports in Programmable Wireless are now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted May 12, 2021 - 15:41 PDT
Update
We are still experiencing usage report delays with the Programmable Wireless product. The issue has no impact on connectivity. We continue working to recover the missing usage records. We will provide another update in 8 hours or as soon as more information becomes available.
Posted May 12, 2021 - 15:10 PDT
Update
We are still experiencing usage report delays with the Programmable Wireless product. The issue has no impact on connectivity. We continue working to recover the missing usage records. We will provide another update in 4 hours or sooner once more information becomes available.
Posted May 12, 2021 - 11:17 PDT
Update
We are still experiencing usage report delays with the Programmable Wireless product. The issue has no impact on connectivity. We continue working to recover the missing usage records. We will provide another update in 2 hours or sooner once more information becomes available.
Posted May 12, 2021 - 09:25 PDT
Investigating
We are experiencing usage report delays with the Programmable Wireless product. The issue has no impact on connectivity. We are working on recovering the missing usage records. We will provide another update in 1 hour or sooner once more information becomes available.
Posted May 12, 2021 - 08:33 PDT
This incident affected: INTERNET OF THINGS (Programmable Wireless).