Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound MMS and MMS DLR Processing for USA and Canada are Failing
      Incident Report for Twilio
      Resolved
      Issues with Inbound MMS and MMS DLR processing for USA and Canada has been resolved and MMS is operating normally at this time.
      Posted May 04, 2021 - 03:24 PDT
      Update
      We are experiencing issues with Inbound MMS and MMS DLR processing for USA and Canada. Our engineers are working to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted May 04, 2021 - 02:46 PDT
      Investigating
      Our monitoring systems have detected a potential issue with Inbound MMS towards Twilio numbers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted May 04, 2021 - 01:41 PDT
      This incident affected: CARRIER NETWORK (MMS Long Code, North America).