Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delays in MMS Delivery to US T-Mobile numbers
      Incident Report for Twilio
      Resolved
      We have resolved the issue impacting MMS delivery delays
      Posted Jun 17, 2017 - 14:03 PDT
      Monitoring
      MMS Delivery performance is operating as expected. We are monitoring to confirm full resolution.
      Posted Jun 17, 2017 - 13:53 PDT
      Investigating
      We are currently investigating an issue with MMS delivery delays to certain numbers. Next update in 30 minutes.
      Posted Jun 17, 2017 - 13:29 PDT
      This incident affected: PROGRAMMABLE MESSAGING (MMS).