Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Report Delay from a Subset US Shortcode Traffic
      Incident Report for Twilio
      Resolved
      We have investigated the issue with an issue with MMS delivery report delay from a subset of US shortcode traffic and it was determined that the impact was minimal. We have reached out to the impacted customers directly and is marking this incident as resolved on StatusPage.
      Posted Jul 21, 2020 - 07:04 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jul 21, 2020 - 06:09 PDT
      This incident affected: CARRIER NETWORK (MMS Short Code, North America).