Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Issues to Orange Egypt Network
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 16, 2019 - 00:28 PDT
Monitoring
We are observing a recovery in SMS delivery to Orange network in Egypt. We will continue to monitor the situation and will provide additional information as it becomes available.
Posted 6 months ago. Apr 15, 2019 - 23:55 PDT
Investigating
The Orange network in Egypt is currently experiencing issues delivering SMS. We are working with the carrier to resolve the issue and will provide additional information as it becomes available.
Posted 6 months ago. Apr 15, 2019 - 21:03 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).