Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SC and LC SMS Delivery Degradation to and from US numbers
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Dec 05, 2019 - 10:45 PST
Monitoring
We are seeing recovery on the delivery degradation to and from a portion of US Short Codes and Long Codes. We'll continue to monitor and provide updates if there are any changes.
Posted Dec 05, 2019 - 09:24 PST
Investigating
We are currently seeing delivery degradation to and from a portion of US Short Codes and Long Codes. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Dec 05, 2019 - 08:44 PST
This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS Short Code, North America).