Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays unsuspending Twilio accounts
Incident Report for Twilio
Resolved
This incident has been resolved. All systems are operational now.
Posted 7 months ago. Nov 23, 2018 - 18:10 PST
Update
Our engineering team continues to work to process delays of un-suspending accounts. We are processing the queue and will provide another update when the queue is caught up.
Posted 7 months ago. Nov 23, 2018 - 09:30 PST
Monitoring
We have identified the issue causing delays un-suspending accounts. We are processing the queue and will provide another update when the queue is caught up.
Posted 7 months ago. Nov 23, 2018 - 07:32 PST
Investigating
We are currently experiencing delays unsuspending customer accounts. We will provide additional information as soon as possible.
Posted 7 months ago. Nov 23, 2018 - 06:23 PST