Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays To Al Madar Libya
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to Al Madar in Libya. This incident has been resolved.
      Posted Mar 28, 2020 - 16:01 PDT
      Monitoring
      We are seeing signs of recovery in SMS delivery delays when sending messages to Al Madar in Libya. We will continue to monitor to ensure a full recovery.
      Posted Mar 28, 2020 - 15:32 PDT
      Update
      Our engineers are still investigating this issue with the underlying carrier. We will provide more updates as soon as they become available.
      Posted Mar 28, 2020 - 12:49 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to Al Madar in Libya. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Mar 28, 2020 - 11:51 PDT