Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Video Compositions are Delayed and Some Others Fail
Incident Report for Twilio
Resolved
We are no longer experiencing delays and failures in some video compositions. This incident has been resolved.
Posted Jul 20, 2021 - 02:08 PDT
Update
The fix was fully deployed and video compositions are now operating normally.
Some recordings generated for rooms created between 2021/07/06 14:41:13 UTC - 2021/07/13 19:04:05 UTC may fail.
We have validated during 3 days that new recording (created after 2021/07/13 19:04:05 UTC) are no longer impacted.
We already have a fix to recover failed compositions. It is pending to be fully tested.
The initial estimation is having it ready by Wednesday 2021/07/21 UTC.
We'll provide another update on 2021/07/21 UTC or as soon as more information becomes available.
Posted Jul 16, 2021 - 02:12 PDT
Update
A fix was fully deployed and video compositions are now operating normally.
Some recordings generated for rooms created between 2021/07/06 14:41:13 UTC - 2021/07/13 19:04:05 UTC may fail.
We have validated during 12 hours that new recording (created after 2021/07/13 19:04:05 UTC) are no longer impacted.
We are looking for a fix to recover failed compositions.
We'll provide another update in 24 hours or as soon as more information becomes available.
Posted Jul 15, 2021 - 02:18 PDT
Identified
The fix was fully deployed and video compositions are now operating normally.
Some recordings generated for rooms created between 2021/07/06 14:41:13 UTC - 2021/07/13 19:04:05 UTC may have failed.
We have validated during 12 hours that new recording (created after 2021/07/13 19:04:05 UTC) are no longer impacted.
We are looking for a fix to recover failed compositions.
We'll provide another update in 24 hours or as soon as more information becomes available.
Posted Jul 14, 2021 - 02:19 PDT
Update
The fix has been fully deployed and video compositions are now operating normally. Some recordings generated for rooms created between 2021/07/06 14:41:13 UTC - 2021/07/13 19:04:05 UTC may fail. We have confirmed that new recordings are no longer impacted, but we will continue to monitor as we look for a fix for the recordings that were impacted during the incident. We'll provide another update in 12 hours or as soon as more information becomes available.
Posted Jul 13, 2021 - 14:24 PDT
Update
The fix has been fully deployed and video compositions are now operating normally. Some recordings generated for rooms created between 2021/07/06 14:41:13 UTC - 2021/07/13 19:04:05 UTC may fail. We are looking for a fix for the recordings that have been impacted. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 13, 2021 - 14:13 PDT
Update
The fix has been fully deployed and video compositions are now operating normally. Some recordings generated for rooms created between 2021/07/06 14:41:13 UTC - 2021/07/13 19:04:05 UTC may fail. We are looking for a fix for the recordings that have been impacted. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Jul 13, 2021 - 13:41 PDT
Monitoring
The fix has been fully deployed and video compositions are now operating normally. Some recordings generated for rooms created between 2021/07/06 14:41:13 UTC - 2021/07/13 19:04:05 UTC may fail. We are looking for a fix for the recordings that have been impacted. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Jul 13, 2021 - 13:05 PDT
Update
We are still waiting on the fix to fully deploy. The fix should be fully deployed within 2 hours and will resolve the video composition delays and failures. As the fix is deployed, impact will gradually decrease. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Jul 13, 2021 - 11:05 PDT
Identified
Our engineers have identified the issue and deployed a fix. The fix will take 4 to 6 hours for the fleet to completely update and resolve the video composition delays and failures. As the fix is deployed, impact will gradually decrease. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Jul 13, 2021 - 07:11 PDT
Update
Our engineering team has deployed a fix, it will take 6 to 8 hours for the fleet to get the fix in order to solve the delays and failures in some video compositions. We expect to provide another update in 2 hour or as soon as more information becomes available
Posted Jul 13, 2021 - 05:12 PDT
Update
We are investigating delays and failures in some video compositions. We expect to provide another update in 1 hour or as soon as more information becomes available
Posted Jul 13, 2021 - 04:13 PDT
Investigating
Our monitoring systems have detected a potential issue with media recordings. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 13, 2021 - 04:02 PDT
This incident affected: PROGRAMMABLE VIDEO (Compositions).