Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Programmable Messaging and SMS Experiencing Delays in Indexing New Messages
      Incident Report for Twilio
      Resolved
      Delays in Indexing new messages has been resolved and Programmable SMS is operating normally at this time.
      Posted Feb 27, 2021 - 02:40 PST
      Monitoring
      We are seeing recovery in indexing of new messages for Programmable Messaging and SMS products. We will continue to monitor to ensure full service recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Feb 27, 2021 - 02:15 PST
      Update
      We continue to investigate the issue and will provide an update in 2 hours or as soon as additional information is available.
      Posted Feb 27, 2021 - 01:42 PST
      Update
      We continue to investigate this issue. We will provide an update in 1 hour or as soon as additional information is available.
      Posted Feb 27, 2021 - 00:28 PST
      Update
      We are experiencing delays in indexing new messages in Programmable Messaging and SMS products. We expect the inbound and outbound message propagation operating normally, however messages are unavailable for queries in real-time and delayed in logs. Messaging Insights data is not delayed and can be used instead.

      We identified a problem with internal service and investigating the root cause. We expect to provide another update in 30 minutes.
      Posted Feb 27, 2021 - 00:05 PST
      Update
      We are continuing to investigate this issue.
      Posted Feb 26, 2021 - 23:48 PST
      Investigating
      Our monitoring systems have detected a potential issue with Programmable Messaging. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Feb 26, 2021 - 23:41 PST
      This incident affected: PROGRAMMABLE MESSAGING (MMS, SMS, Messaging Channels).