Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Elevated Error Rate for Caller Name Lookup API
Incident Report for Twilio
Resolved
Elevated error rate for Caller Name Lookup API has been resolved and Twilio Caller Name Lookup is operating normally at this time.
Posted Feb 11, 2021 - 13:24 PST
Update
We continue seeing recovery from elevated error rates with Caller Name Lookups. Our engineers will continue to monitor until the service is fully restored. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 11, 2021 - 11:24 PST
Update
We continue seeing recovery from elevated error rates with Caller Name Lookups. Our engineers will continue to monitor until the service is fully restored. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 11, 2021 - 10:01 PST
Monitoring
We have started to see recovery from elevated error rates with Caller Name Lookups. Our engineers will continue to monitor until the service is fully restored. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Feb 11, 2021 - 09:32 PST
Investigating
Twilio Lookup Caller Name Lookups is slightly degraded for approximately 30 minutes since 7:38 a.m. Pacific Time on 02/11/2021. A subset of customers may experience slightly elevated errors when performing Caller Name Lookups. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 11, 2021 - 08:35 PST
This incident affected: AUTHY (Lookup).