Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Issue Retrieving Call Records for Completed Calls
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Mar 30, 2021 - 09:33 PDT
Monitoring
The issue causing a subset of call records to be unavailable has been identified and a fix is implemented. We are monitoring the result and will post an update within 30 minutes.
Posted Mar 30, 2021 - 09:04 PDT
Update
The issue causing a subset of call records to be unavailable has been identified. We are continuing to work on availability of completed call records with the Calls API. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Mar 30, 2021 - 07:08 PDT
Update
The issue causing a subset of call records to be unavailable has been identified. We are continuing to work on availability of completed call records with the Calls API. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Mar 29, 2021 - 23:11 PDT
Update
The issue causing a subset of call records to be unavailable has been identified. We are continuing to work on availability of completed call records with the Calls API. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Mar 29, 2021 - 19:15 PDT
Identified
The issue causing a subset of call records to be unavailable has been identified. We are continuing to work on availability of completed call records with the Calls API. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 29, 2021 - 17:18 PDT
Investigating
We are seeing that some calls have not caught up with the Call API and are again investigating. Customers may still see delays retrieving completed call statuses. A retry via the API may be required. We will provide an update in 2 hours or as soon as we have more information.
Posted Mar 29, 2021 - 16:12 PDT
Monitoring
Call API has recovered and is now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Mar 29, 2021 - 15:43 PDT
Update
Update.

We are seeing an improvement in the APIs that deliver completed calls. Customers may still see delays retrieving completed call statuses. A retry via the API may be required.
Posted Mar 29, 2021 - 15:10 PDT
Update
Update information on the issue. Twilio monitoring systems have detected a potential issue with retrieving call records for finished calls. We will provide an update in 2 hours or as soon as we have more information.
Posted Mar 29, 2021 - 12:18 PDT
Investigating
We are investigating intermittent issue with the Call API delivering call records. We will deliver more detail shortly.
Posted Mar 29, 2021 - 12:07 PDT
This incident affected: TWILIO PLATFORM (REST API).