Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Tigo Network in Chad
      Incident Report for Twilio
      Resolved
      We continue investigating the issue with SMS delivery delays to the Tigo network in Chad. We have proceeded to contact the impacted customers directly while we continue working on a resolution with our carrier partner. If you have any questions or concerns please reach out to support.
      Posted Sep 14, 2022 - 16:09 PDT
      Update
      We are still experiencing SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 14, 2022 - 14:47 PDT
      Update
      We are still experiencing SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 13, 2022 - 14:53 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 12, 2022 - 15:06 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 11, 2022 - 15:08 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 10, 2022 - 15:20 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 09, 2022 - 15:20 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 08, 2022 - 15:30 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 07, 2022 - 15:11 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 06, 2022 - 15:10 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
      Posted Sep 05, 2022 - 23:02 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Sep 05, 2022 - 15:10 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Sep 05, 2022 - 11:29 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 05, 2022 - 09:31 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to Tigo network in Chad. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 05, 2022 - 08:33 PDT
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).