Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery Delays to MTN Network in Ghana
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays to MTN Network in Ghana. This incident has been resolved.
Posted Mar 30, 2021 - 20:47 PDT
Monitoring
We are observing successful SMS delivery delays to MTN Network in Ghana. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 30, 2021 - 19:00 PDT
Investigating
We are experiencing SMS delivery delays to MTN Network in Ghana. Our engineers are working with our carrier partner to resolve the issue. We will provide an update in 1 hour or as soon as more information becomes available.
Posted Mar 30, 2021 - 18:06 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).