Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Verify Insights Data Unavailable
      Incident Report for Twilio
      Resolved
      Our engineers detected an issue with our Verify product where Verify Insights data was unavailable from yesterday October 6th at 10:19 PDT until today October 7th at 9:20 PDT. This incident has been resolved and all systems are operational.
      Posted Oct 07, 2020 - 09:40 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Oct 07, 2020 - 09:13 PDT
      This incident affected: ACCOUNT SECURITY (Verify).