Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays To Multiple US Networks Causing Delays in Authy 2FA and Verify Retry Attempts
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays with Authy 2FA and Verify to multiple US networks. This incident has been resolved.
Posted Dec 06, 2021 - 23:27 PST
Update
We continue to observe a recovery in SMS delivery delays with Authy 2FA and Verify to multiple US networks. We will continue to monitor the service to ensure a full recovery and will provide another update in 2 hours or as soon as more information becomes available.
Posted Dec 06, 2021 - 21:40 PST
Monitoring
We are observing a recovery in SMS delivery delays with Authy 2FA and Verify to multiple US networks and will continue to monitor the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Dec 06, 2021 - 19:55 PST
Update
We are investigating intermittent SMS delivery delays with Authy 2FA and Verify to multiple US networks. This is only impacting retry attempts, and not initial messages. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Dec 06, 2021 - 18:00 PST
Update
We are investigating intermittent SMS delivery delays with Authy 2FA and Verify to multiple US networks. This is only impacting retry attempts, and not initial messages. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 06, 2021 - 17:02 PST
Update
We are investigating intermittent SMS delivery delays with Authy 2FA to multiple US networks. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 06, 2021 - 16:44 PST
Investigating
Our monitoring systems have detected a potential issue with SMS Delivery Delays to Multiple US Networks. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Dec 06, 2021 - 16:09 PST
This incident affected: CARRIER NETWORK (SMS Long Code, North America) and ACCOUNT SECURITY (Authy 2FA, Verify).