Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      On Call Engineers are Investigating
      Incident Report for Twilio
      Resolved
      We have now seen recovery, the incident is resolved.
      Posted Mar 20, 2020 - 07:32 PDT
      Update
      We are continuing to investigate this issue.
      Posted Mar 20, 2020 - 06:21 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Mar 20, 2020 - 04:35 PDT
      This incident affected: PROGRAMMABLE MESSAGING (Messaging Channels).