Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays from Twilio to Megafon Russia (250-002)
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Feb 27, 2020 - 00:59 PST
Monitoring
We are observing successful delivery to Megafon Russia. We will continue to monitor to ensure a full recovery.
Posted Feb 27, 2020 - 00:21 PST
Investigating
We are experiencing delivery delays sending to Megafon Russia due to emergency maintenance by the mobile operator on their network infrastructure. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Feb 26, 2020 - 23:18 PST
This incident affected: CARRIER NETWORK (SMS, Europe).