Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays in retrieving message logs
Incident Report for Twilio
Resolved
All processing is caught up and all systems are working as designed.
Posted 6 months ago. Nov 21, 2018 - 16:35 PST
Update
Our engineering team continues to work and is making progress on the recovery of delayed customer logs that some customers might be experiencing.
Posted 6 months ago. Nov 21, 2018 - 12:50 PST
Update
Our engineering team continues to work on the recovery of delayed customer logs that some customers might be experiencing.
Posted 6 months ago. Nov 21, 2018 - 10:48 PST
Identified
We’ve identified a problem which may impact a small percentage of customers, resulting in a delay in showing customers message logs on the Twilio dashboard and REST API. This problem does not affect message delivery. Engineering is engaged and working to resolve the problem.
Posted 6 months ago. Nov 21, 2018 - 09:40 PST
This incident affected: TWILIO PLATFORM (Billing).