Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures on Orange Israel
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery failures to Orange Israel. This incident has been resolved.
      Posted Sep 22, 2020 - 02:41 PDT
      Monitoring
      We are observing successful SMS delivery to Orange Israel. We will continue to monitor to ensure a full recovery of the service. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 22, 2020 - 01:47 PDT
      Update
      We continue to experience message delivery failures when sending to the Orange network in Israel. Our engineering team continues to investigate this issue with our carrier partner. We will provide another update after 16 hours or as soon as more information becomes available.
      Posted Sep 21, 2020 - 16:39 PDT
      Update
      Our engineering team is still investigating this issue with our carrier partner. We will provide another update after 8 hours or as soon as more information becomes available.
      Posted Sep 21, 2020 - 08:35 PDT
      Update
      Our engineering team is still investigating this issue with our carrier partner. We expect to provide another update after 4 hours or as soon as more information becomes available.
      Posted Sep 21, 2020 - 04:36 PDT
      Update
      Our engineering team is still investigating this issue with our carrier partner. We will provide more information as soon as they become available.
      Posted Sep 21, 2020 - 02:16 PDT
      Investigating
      We are experiencing delivery failures sending to Orange in Israel. Our engineers are working with our carrier partner to resolve the issue. We will provide another update as soon as more information becomes available.
      Posted Sep 21, 2020 - 01:14 PDT