Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound calls are failing to Twilio Israel phone numbers
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Feb 01, 2020 - 21:13 PST
      Identified
      We are experiencing issues with inbound calls to Twilio phone numbers in Israel. We are currently working with our providers to resolve the issue.
      Posted Feb 01, 2020 - 17:24 PST
      This incident affected: CARRIER NETWORK (Voice, Middle East & Africa).