Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Super SIM Network Connectivity Issues
Incident Report for Twilio
Resolved
Super SIM network connectivity issue for 2G, 3G and 4G/LTE has been resolved and the services are operating normally at this time.
Posted Apr 23, 2021 - 18:25 PDT
Monitoring
We are now seeing recovery of the network connectivity issue for 2G, 3G and 4G/LTE. We are continuing to monitor for service stability. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 23, 2021 - 16:27 PDT
Update
Some Super SIM customers may be seeing prolonged time to connect or failures for 2G and 3G traffic. We see that 4G/LTE traffic has recovered. Our team is actively working to restore the service with our partner. We will provide another update in 16 hours or as soon as more information becomes available.
Posted Apr 23, 2021 - 13:10 PDT
Update
Some Super SIM customer may be seeing prolonged time to connect to networks where we could see recovery for LTE traffic but still 2G and 3G traffic are impacted. Our team is actively working to restore the service with our partner. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Apr 23, 2021 - 05:10 PDT
Update
Some Super SIM customer may be seeing prolonged time to connect to networks. Our team is actively working to restore the service with our partner. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Apr 23, 2021 - 01:05 PDT
Update
Some Super SIM customer may be seeing prolonged time to connect to networks. Our team is actively working to restore the service with our partner. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 22, 2021 - 22:58 PDT
Identified
Some Super SIM customer may be seeing prolonged time to connect to networks. Our team is actively working to restore the service with our partner. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 22, 2021 - 21:58 PDT
This incident affected: INTERNET OF THINGS (Super SIM).