Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
On Call Engineers are Investigating an issue with customer upgrades and address validation.
Incident Report for Twilio
Resolved
Addresses can be created and validated correctly now. All of our services are up and operational.
Posted May 24, 2020 - 03:05 PDT
Update
We are continuing to investigate this potential issue with customer upgrades.
Posted May 23, 2020 - 23:59 PDT
Investigating
Our monitoring systems have detected a potential issue with customer upgrades and address validation. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted May 23, 2020 - 20:50 PDT