Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Programmable Wireless Usage API Results Incorrect
Incident Report for Twilio
Resolved
Our Programmable Wireless UsageRecords API is operating normally at this time.
Posted Jun 01, 2021 - 10:42 PDT
Monitoring
Our Programmable Wireless UsageRecords API is now operating normally. We will continue to monitor for system stability. We'll provide another update in 60 minutes or as soon as more information becomes available.
Posted Jun 01, 2021 - 09:59 PDT
Identified
Our engineers continue to work on this Programmable Wireless UsageRecords API issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 01, 2021 - 08:15 PDT
Update
We are experiencing an issue where requests to the Programmable Wireless UsageRecords API with a start date before February 1, 2017 returns no results for the period of February 1, 2017 until May 1, 2020 and will not return the billed amounts for any results. Requests with a start date after February 1, 2017 are correctly returning results for the requested period. We are working on a fix. We will provide another update in 1 hour or sooner once more information becomes available.
Posted Jun 01, 2021 - 07:14 PDT
Investigating
Our monitoring systems have detected a potential issue with Programmable Wireless Usage API. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jun 01, 2021 - 06:56 PDT
This incident affected: INTERNET OF THINGS (Programmable Wireless).