Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Multiple Networks in the US for a Subset of Short Codes and Long Codes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending and receiving messages to a subset of Short Codes and Long Codes towards multiple networks in the US. This incident has been resolved.
      Posted May 31, 2023 - 13:27 PDT
      Monitoring
      We are observing recovery in SMS delivery delays when sending and receiving messages to a subset of Short Codes and Long Codes towards multiple networks in the US. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 31, 2023 - 11:35 PDT
      Update
      We are still experiencing SMS delivery delays when sending and receiving messages to a subset of Short Codes and Long Codes towards multiple networks in the US. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available
      Posted May 31, 2023 - 10:49 PDT
      Update
      We are experiencing SMS delivery delays when sending and receiving messages to a subset of Short Codes and Long Codes towards multiple networks in the US. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available
      Posted May 31, 2023 - 09:52 PDT
      Investigating
      Our monitoring systems have detected a potential issue with SMS delays. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted May 31, 2023 - 09:37 PDT
      This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS Short Code, North America).