Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Toll-Free Numbers in the U.S.
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 7 months ago. Jul 21, 2018 - 02:33 PDT
Update
Inbound and outbound toll-free messages are being delivered without delay. We continue to observe delays in delivery receipts (DLRs), however our carrier partner is processing the backlog. We will continue to monitor and will provide an update when the backlog has cleared.
Posted 7 months ago. Jul 20, 2018 - 23:22 PDT
Update
Our carrier partner has identified the root cause of the issue and is working to restore service to inbound and outbound toll-free messages in the United States. We will provide the next update within 60 minutes.
Posted 7 months ago. Jul 20, 2018 - 22:53 PDT
Update
Our carrier partner has experienced a recurrence of the issue causing inbound and outbound message and delivery receipt (DLR) delays to toll-free numbers in the United States. We will provide an update within 60 minutes.
Posted 7 months ago. Jul 20, 2018 - 21:59 PDT
Monitoring
Inbound and outbound toll-free messages are being delivered without delay. We continue to observe delays in delivery receipts (DLRs), however our carrier partner is processing the backlog. SMS delivery is operational.
Posted 7 months ago. Jul 20, 2018 - 18:29 PDT
Update
Our carrier partner has identified the cause of the inbound and outbound toll-free messaging delays and is working to restore service. We will provide an update within 60 minutes.
Posted 7 months ago. Jul 20, 2018 - 18:14 PDT
Update
We continue to work with our carrier partner to resolve the delays impacting inbound and outbound messages between toll-free numbers in the United States. We will provide an update within 2 hours.
Posted 7 months ago. Jul 20, 2018 - 17:43 PDT
Investigating
We are experiencing a recurrence of delivery delays for inbound and outbound messages to toll-free numbers in the United States. Our engineers are working with our carrier partner to restore service. We will provide an update within 60 minutes.
Posted 7 months ago. Jul 20, 2018 - 16:46 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).