Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
US Short Code MMS delivery issues for Sprint handsets
Incident Report for Twilio
Resolved
We have confirmed that that Delivery receipts for MMS are being successfully sent
Posted 10 months ago. Sep 10, 2018 - 14:03 PDT
Monitoring
We are observing that Delivery receipts for MMS are being successfully sent. We will continue to monitor the system.
Posted 10 months ago. Sep 10, 2018 - 12:05 PDT
Investigating
Delivery receipts for MMS sent from some US Short Codes towards Sprint handsets are missing, and mobile-originated MMS messages sent toward Twilio shortcodes are delayed. We are working with our carrier partner to resolve both issues and will provide additional information as it becomes available.
Posted 10 months ago. Sep 10, 2018 - 08:36 PDT
This incident affected: PROGRAMMABLE MESSAGING (MMS).