Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Delay To T-Mobile in the USA using Subset of Long Codes
      Incident Report for Twilio
      Resolved
      We are no longer observing MMS delivery delays to the T-Mobile network in the USA using a subset of long codes. This incident has been resolved.
      Posted Jan 16, 2023 - 18:46 PST
      Monitoring
      We are observing recovery in MMS delivery delays to T-Mobile network in the USA using a subset of long codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 16, 2023 - 17:03 PST
      Update
      We are still experiencing MMS delivery delays to T-Mobile network in the USA using subset of long codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Jan 16, 2023 - 13:07 PST
      Update
      We are still experiencing MMS delivery delays to T-Mobile network in the USA using subset of longcodes. Our engineers are working with our carrier partner]to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 16, 2023 - 11:16 PST
      Investigating
      After a couple of hours monitoring, we are still experiencing MMS delivery delays to T-Mobile network in the USA using subset of longcodes. Our engineers are working with our carrier partner]to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 16, 2023 - 10:16 PST
      Update
      We continue observing recovery in MMS delivery delays when sending messages to T-Mobile network in the USA using subset of longcodes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 16, 2023 - 08:51 PST
      Monitoring
      We are observing recovery in MMS delivery delays when sending messages to T-Mobile network in the USA using subset of longcodes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 16, 2023 - 06:45 PST
      Update
      We are still experiencing MMS delivery delays to T-Mobile network in the USA using subset of longcodes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Jan 16, 2023 - 03:42 PST
      Update
      We are still experiencing MMS delivery delays to T-Mobile network in the USA using subset of longcodes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 16, 2023 - 01:55 PST
      Investigating
      We are experiencing MMS delivery delays to T-Mobile network in the USA using subset of longcodes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 16, 2023 - 01:05 PST
      This incident affected: CARRIER NETWORK (MMS Long Code, North America).