Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery issue to US Verizon from Some Short Codes
Incident Report for Twilio
Resolved
The delivery issues of messages to US Verizon handsets from some Twilio Short Code has been resolved. All systems are operating normally.
Posted 23 days ago. Jan 25, 2019 - 17:12 PST
Investigating
We are investigating an issue with delivery of messages to US Verizon handsets from some Twilio Short Code. We are working with our carrier partners to resolve the issue as quickly as possible. We will provide an update as soon as we have more information.
Posted 24 days ago. Jan 25, 2019 - 15:52 PST
This incident affected: CARRIER NETWORK (SMS Short Code, North America) and PROGRAMMABLE MESSAGING (SMS).