Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Duplicate Messages Delivered to Some Users
      Incident Report for Twilio
      Resolved
      Twilio Programmable Messaging was degraded for 12 minutes between 16:11 and 16:23 Pacific Time on 09/12/2023. During this period of time some users may have received duplicate messages. The issue has now been resolved.
      Posted Sep 12, 2023 - 16:02 PDT
      Investigating
      Our monitoring systems have detected a potential issue with MMS delivery to Verizon network. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 12, 2023 - 15:56 PDT
      This incident affected: CARRIER NETWORK (SMS Long Code, North America).