Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS delays from short codes to T-Mobile
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Sep 20, 2018 - 14:53 PDT
      Update
      We are continuing to investigate this issue.
      Posted Sep 20, 2018 - 13:40 PDT
      Investigating
      We are experiencing delays sending some SMS from US short codes to T-Mobile handsets. Inbound delivery and long code traffic is not affected. Our engineering team is actively working with our partner to get the issue resolved. We will provide an update as soon as possible.
      Posted Sep 20, 2018 - 13:39 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America) and PROGRAMMABLE MESSAGING (SMS).