Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Orange / Altice Network in Dominican Republic
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to Orange / Altice network in Dominican Republic. This incident has been resolved.
      Posted Dec 10, 2024 - 09:01 PST
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to Orange / Altice network in Dominican Republic. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Dec 10, 2024 - 06:54 PST
      Update
      We are still experiencing SMS delivery delays when sending messages to Orange / Altice network in Dominican Republic. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Dec 10, 2024 - 04:54 PST
      Investigating
      We are experiencing SMS delivery delays when sending messages to Orange / Altice network in Dominican Republic. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Dec 10, 2024 - 04:01 PST
      This incident affected: CARRIER NETWORK (SMS Long Code, North America).