Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound SMS delivery to Ethiopia degraded
Incident Report for Twilio
Resolved
Our SMS delivery degradation towards Ethiopia (MTN) is now resolved.
Posted 3 days ago. Jun 14, 2019 - 06:32 PDT
Update
We are still detecting degradation of SMS Service to Ethiopia (MTN). We continue to work with our partners to resolve. We will provide another update in four hours.
Posted 3 days ago. Jun 13, 2019 - 21:10 PDT
Update
We are still detecting degradation of SMS Service to Ethiopia (MTN). We continue to work with our partners to resolve. We will provide another update in four hours.
Posted 4 days ago. Jun 13, 2019 - 13:26 PDT
Update
We are still detecting degradation of SMS Service to Ethiopia (MTN). We continue to work with our partners to resolve. We will provide another update in four hours.
Posted 4 days ago. Jun 13, 2019 - 09:13 PDT
Update
We detected degraded SMS delivery to Ethiopia (MTN). We are continuing the investigation and working with our partners. We will provide an update when we have further information.
Posted 4 days ago. Jun 13, 2019 - 03:18 PDT
Investigating
We have detected degraded SMS delivery to Ethiopia (MTN). We are investigating and working with our partners. We will provide an update when we have further information.
Posted 4 days ago. Jun 12, 2019 - 23:45 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).