Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Report Delays to Multiple Networks in United Kingdom
      Incident Report for Twilio
      Resolved
      We have fully investigated the SMS delivery report delays to multiple networks in the United Kingdom, and it was determined that the impact was limited to a small set of customers, who have been contacted individually to address any concerns. All systems are operational.
      Posted Sep 06, 2024 - 10:51 PDT
      Investigating
      We are experiencing SMS delivery report delays to multiple networks in the United Kingdom. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 06, 2024 - 09:43 PDT
      This incident affected: CARRIER NETWORK (SMS, Europe).