Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Flex insights dashboards is not accessible
      Incident Report for Twilio
      Resolved
      We are no longer experiencing issues with Flex Insights Dashboards not being accesible. This incident has been resolved.
      Posted Mar 25, 2024 - 06:21 PDT
      Monitoring
      We are able to access the Flex insights dashboard now. We will continue to monitor to ensure a full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Mar 25, 2024 - 06:00 PDT
      Identified
      Our monitoring systems have detected a potential issue with Flex insights boards which currently not accessible. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Mar 25, 2024 - 05:34 PDT
      This incident affected: FLEX (Flex Insights).