Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Errors when connecting new accounts with Twilio Connect.
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 23 days ago. Sep 27, 2019 - 11:30 PDT
Monitoring
Our engineering team has deployed a fix for Twilio Connect. We're monitoring to ensure account connections are being established without further trouble.
Posted 23 days ago. Sep 27, 2019 - 11:17 PDT
Identified
Our engineering team has identified the source of the issue with Twilio Connect and is working to address the problem.
Posted 23 days ago. Sep 27, 2019 - 09:50 PDT
Investigating
Our engineering team is investigating an issue with Twilio Connect. Some customers may be experiencing errors when attempting to connect new accounts. We'll provide an update as soon as we have more information.
Posted 23 days ago. Sep 27, 2019 - 08:56 PDT
This incident affected: TWILIO PLATFORM (REST API).