Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Egypt
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 3 months ago. Dec 27, 2018 - 07:29 PST
Update
We are observing recovery in SMS delivery to the Vodafone and Etisalat networks in Egypt. SMS delivery to the Orange network is still degraded. We will provide further updates as soon as we have more information.
Posted 3 months ago. Dec 27, 2018 - 06:11 PST
Investigating
We are observing delivery delays for SMS sent to the Vodafone, Orange and Etisalat networks in Egypt. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted 3 months ago. Dec 27, 2018 - 05:06 PST
This incident affected: PROGRAMMABLE MESSAGING (SMS).